MD-380 Firmware Upgrade Crashes in Windows10

A Place to ask about the TYT range of radios
kx8u
Posts: 2
Joined: Sat Sep 10, 2016 2:53 pm
Call Sign: KX8U

MD-380 Firmware Upgrade Crashes in Windows10

Postby kx8u » Sun Sep 11, 2016 1:34 pm

Adding this post to the technical section:

I have tried numerous firmware downloads and get the same result. It does not seem to be related to the radio. I am able to program the radio just fine with various tools telling me the USB driver is working. The only thing that crashes is UPDATE.EXE. The error is in Chinese. See attachment for the error. I am running a new computer with Windows 10. I have all the updates/patches installed. I have copied STDFU and STTubeDevice30 to SYSTEM32. (Found this recommendation in another blog post. http://www.g0hwc.com/tyt-md-380-dmr-rad ... mware.html)

Any help would be great as I can not update the firmware on my radio. I can program just fine however. Thanks.

KX8U
Attachments
Capture.PNG
Capture.PNG (135.05 KiB) Viewed 1162 times

User avatar
Metradio
Posts: 516
Joined: Sat Jul 18, 2015 1:32 pm
Location: Slough, Berkshire
Call Sign: G7HID

Re: MD-380 Firmware Upgrade Crashes in Windows10

Postby Metradio » Sun Sep 11, 2016 5:37 pm

Could be natures way of saying don't mess with the firmware....

Mike
Connect Systems CS750 and CS800, Hytera PD-365, Motorola DP4600
Raspberry Pi 2 and DV4Mini HotSpot
AOR AR-DV1 Digital Voice Receiver / eSPYonARD
WS1088 / TRX-1 / Whistler Q / UBCD3600XLT

Tyrbiter
Posts: 46
Joined: Wed May 25, 2016 12:05 pm
Call Sign: G8SEZ

Re: MD-380 Firmware Upgrade Crashes in Windows10

Postby Tyrbiter » Mon Sep 12, 2016 11:31 pm

I see that you seem to have a space in the path to the .bin firmware file.

I would suggest trying again using a path without spaces.
Brian

radionutjob
Posts: 13
Joined: Sat Jun 20, 2015 4:00 pm
Call Sign: non yet

Re: MD-380 Firmware Upgrade Crashes in Windows10

Postby radionutjob » Tue Sep 27, 2016 5:17 pm

I tried the compatibility option and it took the version back to xp sp1 / 2 and it seemed to work then. If that fails you can also change it back and or turn the radio off and back on again a couple of times. It might be something to do with the baud rate of the usb connection.


Return to “TYT”

Who is online

Users browsing this forum: No registered users and 1 guest